SWELLのバージョンアップについて

私がホームページ制作で利用しているテンプレート(テーマ)は「SEWLL」と呼ばれるものになります。
私が知る限り、現状(2021年12月時点)で、日本国内において最も人気のあるテンプレートだと思います。

こちらは有料(17,600円)のテンプレートになるのですが、私にご依頼される場合は、テンプレート代は必要ございません

  • 100%GPLのテンプレートなので

ただ、2021年11月に行われた「ver. 2.5.5」のバージョンアップより、ユーザー認証している方以外のアップデートが一切できない仕様となりました。

この仕様にされた背景として、テンプレートを購入していない人が常に最新の機能を利用できるのはいかがなものだろう・・・というテンプレート制作者の思いがあるからです。

私の方で当然、テンプレートを購入してユーザー認証はしていますので、お客様のサイトをバージョンアップさせることは可能ですし、法的な面でも問題ないと言えば問題ないのですが、この制作者の思いを汲み取り、テンプレートを購入していないお客様のアップデートは控えさせて頂いております。

  • 私が行っているのはサイト制作のみになります

ですので、もし常に最新の機能を使いたいということであれば「SWELLの公式サイト」からテンプレートを購入してライセンス登録をして下さい。
ライセンス登録することで、いつでもバージョンアップできますし、公式サイトのフォーラムで質問することもできますので、長く運営を続けるのでしたらこれを機会に購入しておいてもいいかもしれません。(私の基本制作料とほぼ同じ値段ですが・・・)

目次

サイトに不具合が出た場合

もしバージョンアップをしないことにより不具合が出てしまった場合は、ココナラのDMからご連絡頂ければアップデート対応させてもらうつもりです。

ただ、不具合が出てもそれがテンプレートの影響なのか、それ以外なのかって恐らく判断できないと思います。

「ver. 2.5.5」のバージョンで敢えて止めているサイトを持っていますので、そちらのサイトで不具合が出なければ、他の影響で不具合が出ていると判断して基本的には対応しません。

お客様の方で私が入れていないプラグインを導入してそれが原因で不具合が出てしまった場合は一切対応できません。(一番不具合が出る可能性がこれだと思います)

こちらにつきましては、テンプレートの不具合に関わらず何が原因での不具合でも対応できません。(ですので何でもかんでもプラグインを入れることはお勧めしません)

2021年11月時点の最新のバージョン(ver. 2.5.5)を入れていますので、普通に運営していれば、少なくとも以降、1~2年は問題なく運営できると思います。

プラグインの導入以外で、不具合が出るタイミングとしてはワードプレスの大型アップデート(「5.〇.2」の〇の部分が変更)の時ぐらいですですので、もしアップデートした時に表示がおかしくなったら連絡して下さい。
(「5.8.〇」の〇のアップデートは小規模ですので不具合がでることは限りなくありません)

2021年12月13日時点の状況

問題ありません

よかったらシェアしてね!
  • URLをコピーしました!
  • URLをコピーしました!
目次
閉じる